Are you working on getting your CCNA certification? Taking a Cisco Network Academy CCNA/CCNP class? Want get get some more real world experience and use what you are learning on a day-to-day basis? Then you should get a Cisco ISR router for your home and replace your current consumer Internet router.
Before I go on any further, the first scenario that I am going to run through does not include an ISR router with wireless. These are going to be a little harder to come by on the used market for a reasonable price. But I will address this in a second article if you are looking to have a single device for both your router and wireless access-point. However, if you are interested in moving forward with just the router piece and then adding your own access-point, keep reading.
One reason I suggest adding wireless to your network separately from your router is that wireless technology is changing much faster than your router technology. By implementing these in different devices on your network you can upgrade your wireless as the technology changes. In addition, standalone access-points generally have more enterprise features than the wireless router combos that most consumers use. If you are going to pursue a career in enterprise IT/infrastructure, this is a great time to start using enterprise equipment!
Acquire a Cisco ISR Router
This part is going to be a bit tricky and I apologize that I am not going to be able to provide support on any hardware that you acquire. I am just making some good-faith recommendations. But this should be straight forward enough that you should be able to acquire the correct hardware from eBay or other used marketplace. Please make sure you are comfortable with these online platforms and know how to determine which sellers are reputable before purchasing from someone.
For the configurations that we are going to start with, basic CCNA functionality, look for one of the following models:
- Cisco ISR 1921 Router – Approximately $100 – Minimum 512 Mbytes of RAM and 256 Mbytes of Flash
- Cisco ISR 1841 Router – Approximately $50-$75 – Minimum 256 Mbytes of RAM and 64 Mbytes of Flash (128 Mbytes of Flash would be better)
- Cisco 891-W Router – Approximately $40 (This will have wireless built in, make sure what you are buying includes the antennas)
These prices were sampled in April, 2020.
The 891 will include some switch ports in the chassis, the 1841/1921 models will not. So if you go the 1841/1921 route, you will need to make sure you have an external switch.
There are older models that will work just fine with this configuration as well. However, the routers listed above are not much more expensive that the older devices and these will perform best on home Internet connections as you get above 50 Mbits/sec.
When choosing which seller to buy from, make sure the seller is including a Cisco Rollover/Console cable. If can’t find a seller who includes them, you can find them individually as well. Also, remember you may need a USB/Serial DB-9 converter if your laptop/PC does not have a DB-9 serial port.
When evaluating and eBay seller, please make sure you are looking at their ratings and reviews. Only purchase from sellers who have great ratings/reviews and make sure you look at their return policy. Also, do not get too excited by the best price as some of the best prices come with hefty shipping charges.
Getting the Hardware Ready
One you receive your equipment, it is always a good idea to wipe out the configuration, even if it appears that there is not a configuration on the device. To do this you will have to make sure you have a terminal program, console cable,
If you are able to console into the device and get to privilege exec mode, then just do the following:
Router#erase startup-configuration
Router#reload
If you are not able to log into the device because it has a password on the device, then you will have to follow the steps for Cisco IOS Router Password Recovery.
Once the router reloads, remember to skip the menu based configuration that comes up on a new device that does not have a startup-configuration by answering no to the setup question.
--- System Configuration Dialog ---
Would you like to enter the initial configuration dialog? [yes/no]: no
Once you have a router command prompt we can get going.
The next step is to make sure you understand what type of router and interfaces you have. If you have a 1841, you are going to be working with FastEthernet interfaces. If you are working with an 1921, you will have GigabitEthernet interfaces.
The easiest way to determine which interfaces you have is to do a show ip interface brief command:
Router>sh ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES unset administratively down down
GigabitEthernet0/1 unassigned YES unset administratively down down
Router>sh ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
FastEthernet0/1 unassigned YES unset administratively down down
It is important that you know which interfaces you are working with as you will need to modify the configurations below accordingly to match the hardware that you have. Just substitute the FastEthernet interface type for the GigabitEthernet type you see in the configurations below.
I would be best to start to configure your new router before disconnecting your home network and replacing the router. That way if you encounter any issues while you are configuring, you still have access to the Internet to continue reading this/troubleshoot.
Base Feature Requirements
The base configuration that we will show below will replicate the same basic features that your current router provides
- DHCP Client on your external Internet interface
- Basic Routing
- DHCP for your internal network
- Network Address Translation (NAT)
Configuration
First, lets start with the basic router configuration that we would put on any Cisco IOS device:
Router#configure terminal
Router(config)#hostname HomeRouter
HomeRouter(config)#username <yourusername> password <yourpassword>
HomeRouter(config)#enable secret <putyourenablepwhere>
HomeRouter(config)#no ip domain lookup
HomeRouter(config)#ip domain-name <putyourdomainhere>.local
HomeRouter(config)#crypto key generate rsa modulus 1024
HomeRouter(config)#line con 0
HomeRouter(config-line)#login local
HomeRouter(config-line)#logging synchronous
HomeRouter(config-line)#line vty 0 4
HomeRouter(config-line)#login local
HomeRouter(config-line)#logging synchronous
HomeRouter(config-line)#transport input ssh
HomeRouter(config-line)#
Configure your ISP Interface w/DHCP Client
HomeRouter(config)#interface fa0/0
HomeRouter(config-if)#ip address dhcp
HomeRouter(config-if)#no shutdown
HomeRouter(config-if)#
Configure your Internal LAN Interface
HomeRouter(config)#interface fa0/1
HomeRouter(config-if)#ip address 192.168.1.254 255.255.255.0
HomeRouter(config-if)#no shutdown
HomeRouter(config-if)#
Configure the DHCP Server
HomeRouter(config)#ip dhcp pool HOMELAN
HomeRouter(dhcp-config)#network 192.168.1.0 255.255.255.0
HomeRouter(dhcp-config)#default-router 192.168.1.254
HomeRouter(dhcp-config)#dns-server 8.8.8.8
Configure Network Address Translation (NAT)
HomeRouter(config)#access-list 10 permit 192.168.1.0 0.0.0.255
HomeRouter(config)#ip nat inside source list 10 interface fa0/0 overload
HomeRouter(config)#interface fa0/0
HomeRouter(config-if)#ip nat outside
HomeRouter(config-if)#interface fa0/1
HomeRouter(config-if)#ip nat inside
HomeRouter(config-if)#
At this point, you should be able to plug your router interface FastEthernet0/1 into your Ethernet switch and remove your old routers WAN connection to your ISP and plug it into FastEthernet 0/0. Plug your device into your Ethernet switch and you should be good to go!
Leave a Reply